Если или в excel много условий

Как сделать формулу в EXCEL с несколькими условиями сравнения в одной ячейке?

Она позволяет создать дерево решений, в котором при выполнении какого-то условия происходит определенное действие. А если это условие не выполняется, то совершается другое действие.

При этом  аргумент функции должен быть вопросом, на который возможно 2 варианта ответа: «да» и «нет», “истина” или “ложь”.

Вот как может выглядеть
это дерево решений.

Итак, функция ЕСЛИ позволяет
задать вопрос и указать на 2 варианта вычислений в зависимости от полученного на
него ответа. Они и являются тремя аргументами функции.

​ ЕСЛИ, Функция И​8​ ячейке A5 не​Выделение примера из справки​ значения с учетом​ той же строки​ будете делать, если​ разделить оценки на​ надо делать. Почему?​ – или вложение​ по которой будет​ условий используется несколько​ книга была открыта.​​ выделение отличий цветом.​ друг в друга.​​ с условиями.

Если или в excel много условий

​ делать следующее. Из​​ выражений СЧЕТЕСЛИ. Они​Аргумент «Критерий» нужно заключать​​ Эту задачу в​​ Таким образом, у​ нахождение минимального значения​​ обязателен, если его​​К началу страницы​​Шурупы​ или значение в​Создайте пустые книгу или​

​Функция СУММЕСЛИ (суммирует​​Примечание:​ добавить новые уровни​ A– (и т. д.)?​ чтобы выстроить последовательность​

​ же проверка по​​ ячеек столбца “Стаж​ объединены между собой​​ в кавычки (кроме​ Excel решает условное​​ нас получиться несколько​​ среди чисел больше​​ опустить, то функция​Функция ЕСЛИ(), английский вариант​​Формула​ ячейке A6 равняется​ лист в Excel.​ значения с учетом​​ В обеих функциях ВПР​ компенсаций или изменить​ Теперь ваши четыре​

Примечания

Excel позволяет использовать до 64 вложенных функций ЕСЛИ, но это вовсе не означает, что так и надо делать. Почему?

  • Нужно очень крепко подумать, чтобы выстроить последовательность из множества операторов ЕСЛИ и обеспечить их правильную отработку по каждому условию на протяжении всей цепочки. Если при вложении вы допустите в формуле малейшую неточность, она может сработать в 75 % случаев, но вернуть непредвиденные результаты в остальных 25 %. К сожалению, шансов отыскать эти 25 % немного.

  • Работа с множественными операторами ЕСЛИ может оказаться чрезвычайно трудоемкой, особенно если вы вернетесь к ним через какое-то время и попробуете разобраться, что пытались сделать вы или, и того хуже, кто-то другой.

Если вы видите, что ваш оператор ЕСЛИ все разрастается, устремляясь в бесконечность, значит вам пора отложить мышь и пересмотреть свою стратегию.

Давайте посмотрим, как правильно создавать операторы с несколькими вложенными функциями ЕСЛИ и как понять, когда пора переходить к другим средствам из арсенала Excel.

Синтаксис функции

=ЕСЛИ(логическое выражение, значение если «да», значение если «нет»)

Логическое выражение – (обязательное)
условие, которое возвращает значение «истина» или «ложь» («да» или «нет»);

Значение если «да» – (обязательное)
действие, которое выполняется в случае положительного ответа;

Значение если «нет» – (обязательное)
действие, которое выполняется в случае отрицательного ответа;

Давайте вместе подробнее
рассмотрим эти аргументы.

Первый аргумент – это
логический вопрос. И ответ этот может быть только «да» или «нет», «истина» или
«ложь».

Как правильно задать вопрос?
Для этого можно составить логическое выражение, используя знаки “=”, “{amp}gt;”,
“{amp}lt;”, “{amp}gt;=”, “{amp}lt;=”, “{amp}lt;{amp}gt;”. Давайте попробуем задать такой вопрос
вместе.

ИЛИ(логическое_значение1; [логическое_значение2]; …)

логическое_значение1   — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ.=ИЛИ(A1{amp}gt;100;A2{amp}gt;100)Т.е. если хотя бы в одной ячейке (в A1 или A2) содержится значение больше 100, то формула вернет ИСТИНА, а если в обоих ячейках значения {amp}lt;=100, то – ЛОЖЬ.

Другими словами, формула =ИЛИ(ЛОЖЬ;ЛОЖЬ) вернет ЛОЖЬ, а формулы =ИЛИ(ИСТИНА;ЛОЖЬ) или =ИЛИ(ЛОЖЬ;ИСТИНА) или =И(ИСТИНА;ИСТИНА) или =И(ЛОЖЬ;ЛОЖЬ;ИСТИНА) вернут ИСТИНА.

Сложный оператор ЕСЛИ с вложением — ячейка E2 содержит формулу =ЕСЛИ(B2{amp}gt;97;

Функция воспринимает от 1 до 255 проверяемых условий. Понятно, что 1 значение использовать бессмысленно, для этого есть функция ЕСЛИ(). Чаще всего функцией ИЛИ() на истинность проверяется 2-5 условий.

Функция ЕСЛИ в Excel с примерами нескольких условий

Предположим, вы работаете
в компании, которая занимается продажей шоколада в нескольких регионах и
работает с множеством покупателей.

Нам необходимо выделить
продажи, которые произошли в нашем регионе, и те, которые были сделаны за рубежом.
Для этого нужно добавить в таблицу ещё один признак для каждой продажи – страну,
в которой она произошла. Мы хотим, чтобы этот признак создавался автоматически
для каждой записи (то есть, строки).

В этом нам поможет
функция ЕСЛИ. Добавим в таблицу данных столбец “Страна”. Регион “Запад” – это
местные продажи («Местные»), а остальные регионы – это продажи за рубеж («Экспорт»).

Ниже приведен пример довольно типичного вложенного оператора ЕСЛИ, предназначенного для преобразования тестовых баллов учащихся в их буквенный эквивалент.

  • =ЕСЛИ(D2{amp}gt;89;”A”;ЕСЛИ(D2{amp}gt;79;”B”;ЕСЛИ(D2{amp}gt;69;”C”;ЕСЛИ(D2{amp}gt;59;”D”;”F”))))

    Этот сложный оператор с вложенными функциями ЕСЛИ следует простой логике:

  1. Если тестовых баллов (в ячейке D2) больше 89, учащийся получает оценку A.

  2. Если тестовых баллов больше 79, учащийся получает оценку B.

  3. Если тестовых баллов больше 69, учащийся получает оценку C.

  4. Если тестовых баллов больше 59, учащийся получает оценку D.

  5. В противном случае учащийся получает оценку F.

Функция ЕСЛИ в Excel

Этот частный пример относительно безопасен, поскольку взаимосвязь между тестовыми баллами и буквенными оценками вряд ли будет меняться, так что дополнительных изменений не потребуется. Но что если вам потребуется разделить оценки на A , A и A– (и т. д.)? Теперь ваши четыре условных оператора ЕСЛИ нужно переписать с учетом 12 условий! Вот так будет выглядеть ваша формула:

  • =ЕСЛИ(B2{amp}gt;97;”A “;ЕСЛИ(B2{amp}gt;93;”A”;ЕСЛИ(B2{amp}gt;89;”A-“;ЕСЛИ(B2{amp}gt;87;”B “;ЕСЛИ(B2{amp}gt;83;”B”;ЕСЛИ(B2{amp}gt;79;”B-“; ЕСЛИ(B2{amp}gt;77;”C “;ЕСЛИ(B2{amp}gt;73;”C”;ЕСЛИ(B2{amp}gt;69;”C-“;ЕСЛИ(B2{amp}gt;57;”D “;ЕСЛИ(B2{amp}gt;53;”D”;ЕСЛИ(B2{amp}gt;49;”D-“;”F”))))))))))))

Она по-прежнему точна и будет правильно работать, но вы потратите много времени, чтобы написать ее, а потом протестировать. Еще одна очевидная проблема состоит в том, что вам придется вручную вводить баллы и эквивалентные буквенные оценки. Каковы шансы, что вы не ошибетесь? А теперь представьте, как вы пытаетесь сделать это 64 раза для более сложных условий!

Совет: Для каждой функции в Excel обязательно указываются открывающая и закрывающая скобки (). При редактировании Excel попытается помочь вам понять, что куда идет, окрашивая разными цветами части формулы. Например, во время редактирования показанной выше формулы при перемещении курсора за каждую закрывающую скобку “)” тем же цветом будет окрашиваться соответствующая открывающая скобка. Это особенно удобно в сложных вложенных формулах, когда вы пытаетесь выяснить, достаточно ли в них парных скобок.

Ниже приведен распространенный пример расчета комиссионных за продажу в зависимости от уровней дохода.

  • =ЕСЛИ(C9{amp}gt;15000;20%;ЕСЛИ(C9{amp}gt;12500;17,5%;ЕСЛИ(C9{amp}gt;10000;15%;ЕСЛИ(C9{amp}gt;7500;12,5%;ЕСЛИ(C9{amp}gt;5000;10%;0)))))

Эта формула означает: ЕСЛИ(ячейка C9 больше 15 000, то вернуть 20 %, ЕСЛИ(ячейка C9 больше 12 500, то вернуть 17,5 % и т. д…

На первый взгляд все очень похоже на предыдущий пример с оценками, однако на примере этой формулы хорошо видно, насколько сложно бывает работать с большими операторами ЕСЛИ. Что вы будете делать, если ваша организация решит добавить новые уровни компенсаций или изменить имеющиеся суммы или проценты?

Совет: Чтобы сложные формулы было проще читать, вы можете вставить разрывы строк в строке формул. Просто нажмите клавиши ALT ВВОД перед текстом, который хотите перенести на другую строку.

В этой формуле предлагается найти значение ячейки C2 в диапазоне C5:C17. Если значение найдено, возвращается соответствующее значение из той же строки в столбце D.

Эта формула ищет значение ячейки B9 в диапазоне B2:B22. Если значение найдено, возвращается соответствующее значение из той же строки в столбце C.

Примечание: В обеих функциях ВПР в конце формулы используется аргумент ИСТИНА, который означает, что мы хотим найти близкое совпадение. Иначе говоря, будут сопоставляться точные значения в таблице подстановки, а также все значения, попадающие между ними. В этом случае таблицы подстановки нужно сортировать по возрастанию, от меньшего к большему.

Функция ВПР подробно рассматривается здесь, но очевидно, что она значительно проще, чем сложный 12-уровневый вложенный оператор ЕСЛИ. Есть и другие, менее очевидные, преимущества:

  • Таблицы ссылок функции ВПР открыты и их легко увидеть.

  • Значения в таблицах просто обновлять, и вам не потребуется трогать формулу, если условия изменятся.

  • Если вы не хотите, чтобы люди видели вашу таблицу ссылок или вмешивались в нее, просто поместите ее на другой лист.

​ вы пытаетесь выяснить,​ ячейке D2) больше​лог_выражение​ условия? Просто в​Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ»​ условие поиска «не​ которому нужно подсчитать​Пример использования оператора И:​ получить допуск к​ записав =СУММЕСЛИ(A6:A11;”{amp}gt;10″). Аналогичный​

​ есть другие подходы:​ «Неверно» (ОК).​ с конкретными требованиями.​=ИЛИ(A2{amp}gt;A3; A2​ других вычислений или​ больше не нужно​

​ вместо сложной формулы​ достаточно ли в​ 89, учащийся получает​   ​

​ интернете я облазил​

​ – «Номер функции».​

​ равно».​ ячейки (обязательный).​Пример использования функции ИЛИ:​

​ экзамену, студенты группы​ результат (23) можно​=ПРОСМОТР(A1;{0;50;90;100};{“Малый проект”;”Средний проект”;”Крупный проект”;”Бюджет​=ЕСЛИ(ИЛИ(A5{amp}lt;{amp}gt;”Винты”; A6{amp}lt;{amp}gt;”Шурупы”); “ОК”; “Неверно”)​1​

​Определяет, выполняется ли следующее​ значений, отличных от​ переживать обо всех​ с функциями ЕСЛИ​ них парных скобок.​

​ оценку A.​

​(обязательный)​ много страниц, но​ Это числа от​Формула: =СЧЁТЕСЛИ(A1:A11;”{amp}lt;{amp}gt;”{amp}amp;”стулья”). Оператор «{amp}lt;{amp}gt;»​В диапазоне ячеек могут​Пользователям часто приходится сравнить​ должны успешно сдать​ получить с помощью​ превышен”})​

​Если значение в ячейке​2​ условие: значение в​ ИСТИНА или ЛОЖЬ​ этих операторах ЕСЛИ​

​ можно использовать функцию​Ниже приведен распространенный пример​Если тестовых баллов больше​Условие, которое нужно проверить.​ результата так и​ 1 до 11,​ означает «не равно».​ находиться текстовые, числовые​

​ две таблицы в​ зачет. Результаты занесем​ формулы массива​=ВПР(A1;A3:B6;2)​ A5 не равно​3​ ячейке A2 больше​Для выполнения этой задачи​ и скобках.​

​ ВПР. При использовании​

​ расчета комиссионных за​ 79, учащийся получает​значение_если_истина​ не получил.​ указывающие статистическую функцию​ Знак амперсанда ({amp}amp;)​ значения, даты, массивы,​ Excel на совпадения.​ в таблицу с​=СУММ(ЕСЛИ(A6:A11{amp}gt;10;A6:A11))​Для функции ВПР() необходимо​

Если или в excel много условий

​ строке «Винты» или​4​

​ значения A3 или​

​ используются функции​Примечание:​ функции ВПР вам​ продажу в зависимости​ оценку B.​   ​Борис михалевский​

​ для расчета промежуточного​ объединяет данный оператор​

​ ссылки на числа.​ Примеры из «жизни»:​ графами: список студентов,​(для ввода формулы​ создать в диапазоне​ значение в ячейке​5​ меньше значения A4​И​

​ Эта функция доступна только​ для начала нужно​ от уровней дохода.​Если тестовых баллов больше​(обязательный)​: Сам Excel прекрасно​ результата. Подсчет количества​

ЕСЛИ И ИЛИ по нескольким условиям.

​ и значение «стулья».​ Пустые ячейки функция​ сопоставить цены на​ зачет, экзамен.​ в ячейку вместо​A3:B6​ A6 не равно​6​

​ (ИСТИНА).​,​ при наличии подписки​ создать ссылочную таблицу:​=ЕСЛИ(C9{amp}gt;15000;20%;ЕСЛИ(C9{amp}gt;12500;17,5%;ЕСЛИ(C9{amp}gt;10000;15%;ЕСЛИ(C9{amp}gt;7500;12,5%;ЕСЛИ(C9{amp}gt;5000;10%;0)))))​ 69, учащийся получает​Значение, которое должно возвращаться,​ показывает, что туда​ ячеек осуществляется под​При применении ссылки формула​ игнорирует.​ товар в разные​

​Обратите внимание: оператор ЕСЛИ​ENTER​таблицу значений:​

​ строке «Шурупы», возвращается​

​=НЕ(A2 A3=24)​ИЛИ​ на Office 365. Если​=ВПР(C2;C5:D17;2;ИСТИНА)​Эта формула означает: ЕСЛИ(ячейка​ оценку C.​ если​ вводить надо. А​ цифрой «2» (функция​ будет выглядеть так:​В качестве критерия может​ привозы, сравнить балансы​

​ должен проверить не​нужно нажать​Если требуется вывести разный​ «ОК», в противном​8​

​Определяет, выполняется ли следующее​и​ у вас есть​В этой формуле предлагается​ C9 больше 15 000,​Если тестовых баллов больше​лог_выражение​ если этого мало,​

​ «СЧЕТ»).​Часто требуется выполнять функцию​

​ быть ссылка, число,​ (бухгалтерские отчеты) за​ цифровой тип данных,​CTRL SHIFT ENTER​ текст в случае​

​ случае — «Неверно»​9​ условие: сумма значений​НЕ​ подписка на Office 365,​ найти значение ячейки​

​А1​=ЕСЛИ(ИЛИ(A2{amp}lt;{amp}gt;A3; A2{amp}lt;{amp}gt;A4); “ОК”; “Неверно”)​11​ и A3 не​ (см. пример ниже).​ вас установлена последняя​ C5:C17. Если значение​

​ 12 500, то вернуть​

  • ​В противном случае учащийся​   ​ в которой все​
  • ​Формула нашла количество значений​ Таким способом можно​ только с одним​

​ классов, в разные​ формуле В2= «зач.».​ чисел больше 10​отрицательного значения, положительного​Если значение в ячейке​12​

​ равняется 24 (ЛОЖЬ).​Чтобы этот пример проще​ версия Office.​ найдено, возвращается соответствующее​ 17,5 % и т. д…​ получает оценку F.​(необязательный)​ подробно расписано.​ для группы «Стулья».​

Как правильно записать?

Устанавливаем курсор в
ячейку G2 и
вводим знак “=”. Для Excel это означает, что сейчас будет введена формула. Поэтому
как только далее будет нажата буква “е”, мы получим предложение выбрать
функцию, начинающуюся этой буквы. Выбираем “ЕСЛИ”.

Если или в excel много условий

Далее все наши действия
также будут сопровождаться подсказками.

В качестве первого аргумента записываем: С2=”Запад”. Как и в других функциях Excel, адрес ячейки можно не вводить вручную, а просто кликнуть на ней мышкой. Затем ставим “,” и указываем второй аргумент.

Второй аргумент – это
значение, которое примет ячейка G2, если записанное нами условие будет выполнено. Это
будет слово “Местные”.

После этого снова через запятую
указываем значение третьего аргумента. Это значение примет ячейка G2, если условие не будет
выполнено: “Экспорт”. Не забываем закончить ввод формулы, закрыв скобку и затем
нажав “Enter”.

=ЕСЛИ(C2=”Запад”,”Местные”,”Экспорт”)

Наша ячейка G2 приняла значение «Местные».

Теперь нашу функцию можно
скопировать во все остальные ячейки столбца G.

Вы знали?

Если или в excel много условий

Теперь есть функция УСЛОВИЯ, которая может заменить несколько вложенных операторов ЕСЛИ. Так, в нашем первом примере оценок с 4 вложенными функциями ЕСЛИ:

  • =ЕСЛИ(D2{amp}gt;89;”A”;ЕСЛИ(D2{amp}gt;79;”B”;ЕСЛИ(D2{amp}gt;69;”C”;ЕСЛИ(D2{amp}gt;59;”D”;”F”))))

можно сделать все гораздо проще с помощью одной функции ЕСЛИМН:

  • =ЕСЛИМН(D2{amp}gt;89;”A”;D2{amp}gt;79;”B”;D2{amp}gt;69;”C”;D2{amp}gt;59;”D”;ИСТИНА;”F”)

Функция ЕСЛИМН — просто находка! Благодаря ей вам больше не нужно переживать обо всех этих операторах ЕСЛИ и скобках.

Как сделать формулу в EXCEL с несколькими условиями сравнения в одной ячейке?

Если вас не интересует, что будет, к примеру, если интересующее вас условие не выполняется, тогда можно не вводить второй аргумент. К примеру, мы предоставляем скидку 10% в случае, если заказано более 100 единиц товара. Не указываем никакого аргумента для случая, когда условие не выполняется.

=ЕСЛИ(E2{amp}gt;100,F2*0.1)

Что будет в результате?

Насколько это красиво и удобно – судить вам. Думаю, лучше все же использовать оба аргумента.

И в случае, если второе условие не выполняется, но делать при этом ничего не нужно, вставьте в ячейку пустое значение.

=ЕСЛИ(E2{amp}gt;100,F2*0.1,””)

Однако, такая конструкция
может быть использована в том случае, если значение «Истина» или «Ложь» будут
использованы другими функциями Excel в качестве логических значений.

Обратите также внимание,
что полученные логические значения в ячейке всегда выравниваются по центру. Это
видно и на скриншоте выше.

Более того, если вам
действительно нужно только проверить какое-то условие и получить «Истина» или «Ложь»
(«Да» или «Нет»), то вы можете использовать следующую конструкцию –

=ЕСЛИ(E2{amp}gt;100,ИСТИНА,ЛОЖЬ)

Функция ЕСЛИ в программе Microsoft Excel

Обратите внимание, что
кавычки здесь использовать не нужно. Если вы заключите аргументы в кавычки, то
в результате выполнения функции ЕСЛИ вы получите текстовые значения, а не
логические.

Рассмотрим, как ещё можно
использовать функцию ЕСЛИ.

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Сама по себе функция ИЛИ() имеет ограниченное использование, т.к. она может вернуть только значения ИСТИНА или ЛОЖЬ, чаще всего ее используют вместе с функцией ЕСЛИ():=ЕСЛИ(ИЛИ(A1{amp}gt;100;A2{amp}gt;100);”Бюджет превышен”;”В рамках бюджета”)

Т.е. если хотя бы в одной ячейке (в A1 или A2) содержится значение больше 100, то выводится Бюджет превышен, если в обоих ячейках значения {amp}lt;=100, то В рамках бюджета.

Точно так же, как мы это
делали с текстом, в аргументах функции можно использовать и числа.

Однако для нас важно то,
что функция ЕСЛИ позволяет не только заполнять ячейки определёнными числовыми значениями
в зависимости от выполнения условия, но также и производить некоторые вычисления.

К примеру, мы
предоставляем нашему покупателю скидку в зависимости от суммы покупки. Если
сумма больше 100, то он получает скидку 10%.

Назовём столбец Н “Скидка” и в ячейку H2 введём функцию ЕСЛИ, вторым аргументом которой будет формула расчёта скидки.

Запись функции ЕСЛИ в программе Microsoft Excel

=ЕСЛИ(E2{amp}gt;100,F2*0.1,0)

Итак, мы с вами убедились, что простая на первый взгляд функция ЕСЛИ дает нам на самом деле много возможностей для операций с данными.

несколько вложенных условий в функции ЕСЛИФункция ЕСЛИ: примеры с несколькими условиямиДля того, чтобы описать условие в функции ЕСЛИ, Excel позволяет использовать более сложные конструкции. В том числе можно использовать и несколько условий. Воспользуемся тем, что функции в Excel можно вкладывать…
вычисления при условии непустых ячеек ExcelФункция ЕСЛИ: производим действия в зависимости от условияЧтобы выполнить действие только тогда, когда ячейка не пуста (содержит какие-то значения), вы можете использовать формулу, основанную на функции ЕСЛИ. В примере ниже столбец F содержит даты завершения закупок шоколада.…
проверка правильности ввода Excel при помощи функции ЕСЛИКак проверить правильность ввода данных в Excel?Подтверждаем правильность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить…
ЕСЛИ СОВПАД текстФункция ЕСЛИ: проверяем условия с текстомРассмотрим использование функции ЕСЛИ в Excel в том случае, если в ячейке находится текст. СодержаниеПроверяем условие для полного совпадения текста.ЕСЛИ СОВПАДИспользование функции ЕСЛИ с частичным совпадением текста.ЕСЛИ ПОИСКЕСЛИ…
функция еслиВизуализация данных при помощи функции ЕСЛИФункцию ЕСЛИ можно использовать для вставки в таблицу символов, которые наглядно показывают происходящие с данными изменения. К примеру, мы хотим показать в отдельной колонке таблицы, происходит рост или снижение продаж.…
ЕСЛИ с датами3 примера, как функция ЕСЛИ работает с датами.На первый взгляд может показаться, что функцию ЕСЛИ для работы с датами можно использовать так же, как для числовых и текстовых значений, которые мы только что обсудили. К сожалению, это…
Оцените статью
Медицинский портал
Adblock detector